Summary: Lightweight C library which eases the writing of UNIX daemons
Name: libdaemon
Version: 0.14
Release: r0
License: LGPLv2.1+
Group: libs
Packager: Poky <poky@lists.yoctoproject.org>
URL: http://0pointer.de/lennart/projects/libdaemon/
BuildRequires: autoconf-native
BuildRequires: automake-native
BuildRequires: gnu-config-native
BuildRequires: libtool-cross
BuildRequires: libtool-native
BuildRequires: pkgconfig-native
BuildRequires: virtual/aarch64-poky-linux-compilerlibs
BuildRequires: virtual/aarch64-poky-linux-gcc
BuildRequires: virtual/libc

%description
Lightweight daemon framework for OpenBSD. It provides facilities for
logging and a signal handler to enable graceful shutdown, as well as file
locking to ensure that only a single copy of a given daemon is running at a
time.

%package -n libdaemon-src
Summary: Lightweight C library which eases the writing of UNIX daemons - Source files
License: LGPLv2.1+
Group: devel

%description -n libdaemon-src
Lightweight daemon framework for OpenBSD. It provides facilities for
logging and a signal handler to enable graceful shutdown, as well as file
locking to ensure that only a single copy of a given daemon is running at a
time.  This package contains sources for debugging purposes.

%package -n libdaemon-dbg
Summary: Lightweight C library which eases the writing of UNIX daemons - Debugging files
License: LGPLv2.1+
Group: devel
Recommends: glibc-dbg

%description -n libdaemon-dbg
Lightweight daemon framework for OpenBSD. It provides facilities for
logging and a signal handler to enable graceful shutdown, as well as file
locking to ensure that only a single copy of a given daemon is running at a
time.  This package contains ELF symbols and related sources for debugging
purposes.

%package -n libdaemon-staticdev
Summary: Lightweight C library which eases the writing of UNIX daemons - Development files (Static Libraries)
License: LGPLv2.1+
Group: devel
Requires: libdaemon-dev = 0.14-r0

%description -n libdaemon-staticdev
Lightweight daemon framework for OpenBSD. It provides facilities for
logging and a signal handler to enable graceful shutdown, as well as file
locking to ensure that only a single copy of a given daemon is running at a
time.  This package contains static libraries for software development.

%package -n libdaemon-dev
Summary: Lightweight C library which eases the writing of UNIX daemons - Development files
License: LGPLv2.1+
Group: devel
Requires: libdaemon0 = 0.14-r0
Recommends: glibc-dev

%description -n libdaemon-dev
Lightweight daemon framework for OpenBSD. It provides facilities for
logging and a signal handler to enable graceful shutdown, as well as file
locking to ensure that only a single copy of a given daemon is running at a
time.  This package contains symbolic links, header files, and related
items necessary for software development.

%package -n libdaemon-doc
Summary: Lightweight C library which eases the writing of UNIX daemons - Documentation files
License: LGPLv2.1+
Group: doc

%description -n libdaemon-doc
Lightweight daemon framework for OpenBSD. It provides facilities for
logging and a signal handler to enable graceful shutdown, as well as file
locking to ensure that only a single copy of a given daemon is running at a
time.  This package contains documentation.

%package -n libdaemon-locale
Summary: Lightweight C library which eases the writing of UNIX daemons
License: LGPLv2.1+
Group: libs

%description -n libdaemon-locale
Lightweight daemon framework for OpenBSD. It provides facilities for
logging and a signal handler to enable graceful shutdown, as well as file
locking to ensure that only a single copy of a given daemon is running at a
time.

%package -n libdaemon0
Summary: Lightweight C library which eases the writing of UNIX daemons
License: LGPLv2.1+
Group: libs
Requires: ld-linux-aarch64.so.1()(64bit)
Requires: ld-linux-aarch64.so.1(GLIBC_2.17)(64bit)
Requires: libc.so.6()(64bit)
Requires: libc.so.6(GLIBC_2.17)(64bit)
Requires: libc6 >= 2.31+git0+4f0a61f753
Requires: rtld(GNU_HASH)
Requires(post): ld-linux-aarch64.so.1()(64bit)
Requires(post): ld-linux-aarch64.so.1(GLIBC_2.17)(64bit)
Requires(post): libc.so.6()(64bit)
Requires(post): libc.so.6(GLIBC_2.17)(64bit)
Requires(post): libc6 >= 2.31+git0+4f0a61f753
Requires(post): rtld(GNU_HASH)
Provides: libdaemon = 0.14
Provides: libdaemon.so.0()(64bit)

%description -n libdaemon0
Lightweight daemon framework for OpenBSD. It provides facilities for
logging and a signal handler to enable graceful shutdown, as well as file
locking to ensure that only a single copy of a given daemon is running at a
time.

%post -n libdaemon0
# libdaemon0 - postinst
#!/bin/sh
set -e
if [ x"$D" = "x" ]; then
	if [ -x /sbin/ldconfig ]; then /sbin/ldconfig ; fi
fi


%files -n libdaemon-src
%defattr(-,-,-,-)
%dir "/usr"
%dir "/usr/src"
%dir "/usr/src/debug"
%dir "/usr/src/debug/libdaemon"
%dir "/usr/src/debug/libdaemon/0.14-r0"
%dir "/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14"
%dir "/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dsignal.c"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dexec.c"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dfork.c"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dpid.c"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dnonblock.h"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dnonblock.c"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dpid.h"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dlog.h"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dlog.c"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dsignal.h"
"/usr/src/debug/libdaemon/0.14-r0/libdaemon-0.14/libdaemon/dfork.h"

%files -n libdaemon-dbg
%defattr(-,-,-,-)
%dir "/usr"
%dir "/usr/lib"
%dir "/usr/lib/.debug"
"/usr/lib/.debug/libdaemon.so.0.5.0"

%files -n libdaemon-dev
%defattr(-,-,-,-)
%dir "/usr"
%dir "/usr/include"
%dir "/usr/lib"
%dir "/usr/include/libdaemon"
"/usr/include/libdaemon/dnonblock.h"
"/usr/include/libdaemon/dexec.h"
"/usr/include/libdaemon/dpid.h"
"/usr/include/libdaemon/dlog.h"
"/usr/include/libdaemon/daemon.h"
"/usr/include/libdaemon/dsignal.h"
"/usr/include/libdaemon/dfork.h"
%dir "/usr/lib/pkgconfig"
"/usr/lib/libdaemon.so"
"/usr/lib/pkgconfig/libdaemon.pc"

%files -n libdaemon-doc
%defattr(-,-,-,-)
%dir "/usr"
%dir "/usr/share"
%dir "/usr/share/doc"
%dir "/usr/share/doc/libdaemon"
"/usr/share/doc/libdaemon/style.css"
"/usr/share/doc/libdaemon/README.html"

%files -n libdaemon0
%defattr(-,-,-,-)
%dir "/usr"
%dir "/usr/lib"
"/usr/lib/libdaemon.so.0"
"/usr/lib/libdaemon.so.0.5.0"